CVE-2026-115915:vLLM 允許未受信任 EPS 輸入觸發拒絕服務或 Ghostscript RCE
CVE-2026-115915 - vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE
vLLM 0.32.0 以後已修復,使用者須即時升級並檢查 Pillow 版本,以防止 EPS 造成的拒絕服務或 Ghostscript RCE。
- 受影響產品:vLLM 及其相關依賴 Pillow 12.0.0‑12.2.0。
vLLM 0.32.0 以後已修復,使用者須即時升級並檢查 Pillow 版本,以防止 EPS 造成的拒絕服務或 Ghostscript RCE。
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.
Impact
Affected Products
The following products are affected by CVE-2026-115915
vulnerability.
Even if cvefeed.io is aware of the exact versions of the
products
that
are
affected, the information is not represented in the table below.
| ID | Vendor | Product | Action |
|---|---|---|---|
| 1 | Vllm-project | vllm | |
| 1 | Vllm | vllm |
The Common Vulnerability Scoring System is a standardized framework for assessing the severity of vulnerabilities in software and systems. We collect and displays CVSS scores from various sources for each CVE.
| Score | Version | Severity | Vector | Exploitability Score | Impact Score | Source |
|---|---|---|---|---|---|---|
| CVSS 3.1 | HIGH | MITRE-CVE | ||||
| CVSS 3.1 | HIGH | [email protected] |
Update vLLM to 0.32.0 or later to fix image parsing vulnerabilities.
- Update vLLM to version 0.32.0 or later.
- Ensure Pillow is updated to a non-vulnerable version.
- Disable image loading if Ghostscript is not needed.
Here, you will find a curated list of external links that provide in-depth
information, practical solutions, and valuable tools related to
CVE-2026-115915.
While CVE identifies
specific instances of vulnerabilities, CWE categorizes the common flaws or
weaknesses that can lead to vulnerabilities. CVE-2026-115915 is
associated with the following CWEs:
Common Attack Pattern Enumeration and Classification
(CAPEC)
stores attack patterns, which are descriptions of the common attributes and
approaches employed by adversaries to exploit the CVE-2026-115915
weaknesses.
We scan GitHub repositories to detect new proof-of-concept exploits. Following list is a collection of public exploits and proof-of-concepts, which have been published on GitHub (sorted by the most recently updated).
Results are limited to the first 15 repositories due to potential performance issues.
The following list is the news that have been mention
CVE-2026-115915 vulnerability anywhere in the article.
The following table lists the changes that have been made to the
CVE-2026-115915 vulnerability over time.
Vulnerability history details can be useful for understanding the evolution of a vulnerability, and for identifying the most recent changes that may impact the vulnerability's severity, exploitability, or other characteristics.
-
New CVE Received by [email protected]
十月. 26, 2026
Action Type Old Value New Value Added Description vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0. Added CVSS V3.1 AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H Added CWE CWE-20 Added CWE CWE-183 Added Affected New affected value received. <a href="https://github.com/CVEProject/cvelistV5/blob/main/cves/2026/115xxx/CVE-2026-115915.json">CVE-2026-115915</a> Added Reference https://github.com/vllm-project/vllm/commit/710ac56e691d4713feca50a43e6c440f07d373fd Added Reference https://github.com/vllm-project/vllm/pull/60022 Added Reference https://github.com/vllm-project/vllm/releases/tag/v0.32.0 Added Reference https://github.com/vllm-project/vllm/security/advisories/GHSA-h3rc-j82p-2c3h
EPSS is a daily estimate of the probability of exploitation activity being observed over the next 30 days. Following chart shows the EPSS score history of the vulnerability.